PHP on Windows Hyper-V

Discussion in 'Hyper-V Windows VPS Hosting' started by AndyLL, May 28, 2014.

  1. AndyLL

    AndyLL Perch

    Perhaps I should have asked this question before I started down the multi server path.

    My VPS has 2 Gigs memory ( I think ). It's only running about 10 low traffic websites right now.

    I created a domain:

    in I installed IPBoard.

    I had no problems the 1st night... created and set it up just fine.

    Since then I get to the main forum page fine but I get 500 errors trying to sign into the forums.

    Is this a PHP memory problem? I did not see the option to allocate more memory to PHP in the domain settings.

    Invision won't provide technical support if their software is install on an IIS machine.

    Both the domain and forum are expected to be low volume. Should IIS be able to handle this?
  2. Stephen

    Stephen US Operations Staff Member

    IIS will easily handle this but it would be interesting to know how you have PHP setup, did you use the windows platform installer and install php and fastcgi from it? that will be the best route if you didn't do that maybe work installing and going that route.

    Fastcgi won't need more than 64MB of RAM or so for a lot of PHP processes, regular CGI will need a certain amount of ram per process(hit) it can vary from 5MB to 30-40MB per process/hit depending on config. ISAPI can be used but not recommended, so fastCGI is definitely the way to go.
  3. AndyLL

    AndyLL Perch

    I didn't install it so maybe Plesk did? I will check those settings.

    When I installed IPBoard it stated that 135 meg was available for PHP and that was the min requirement.

    I'm wondering if it is something other then PHP that is causing the 500 error. What types of things cause a 500? Would a SQL Query timeout do that?

    It only seems to happen when I submit a login or new registration. I turned on facebook integration and it seems to have happened sometime after that. Unfortionately since I can't log in I can't turn it off easily.
  4. Stephen

    Stephen US Operations Staff Member

    oh Plesk does fastcgi on php, so that's not the issue. The underlying error needs to be found by disabling the friendly errors and showing error details. Submit a ticket and we can check it out for you to aid in resolving.
  5. AndyLL

    AndyLL Perch

    Did that:
    C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP53\php-cgi.exe - The FastCGI process exceeded configured request timeout

    Last night I checked the domain to use the latest version of PHP installed, bumped up the php memory to 512, bumped up the timeout from 30-120.

    I then deleted the forum software and started from scratch in case I had changed a setting that caused it and tried to re-install

    None helped. In fact I couldn't get through the installation. ( It actually timed out trying to display the EULA screen)

    I'm in the process of upgrading Pleak to 11.5 which comes with a newer version of PHP.

    If that doesn't work I'll submit a ticket.
  6. AndyLL

    AndyLL Perch

    What is really strange about this Stephen is that I installed the forum last Sunday and it went flawlessly. I was in and out of the forums and forum setup screens most of the evening without an error.

    The next day I went back and all of a sudden the 500 errors kept happening. Doesn't make sense.

    It's acting like a true timeout but I don't know with what. It's not the DB because now it's timing out before I get to the DB setup.

    Maybe the software queries the IPBoard website and that's what is timing out. Do know why it would... all other websites are working fine.

    The PHP forums are running in a subdirectory of a ASP.Net domain and I likely made changes to the .Net application but that shouldn't make a difference.

    My next step if the new PHP version does not work is to grant full RW access to the entire subdirectory... maybe it is timing out trying to write out a file.
  7. AndyLL

    AndyLL Perch

    Upgrading Plesk to 11.5 ( and using the latest PHP version they support ) did not work.

    Granting full read/write to the directories did not work.

    I submitted a ticket: MMQ-uv93U-830
  8. AndyLL

    AndyLL Perch


    For those that run into the same problem here is the issue and solution.

    I wiped the domain and started over.

    I installed the forum into without uploading the application into the root.

    I then uploaded my application and the forums starting failing.

    So obviously .Net and PHP were conflicting.

    After much work and commenting out sections of my web.config I found that 1 or more of my http modules were the issue.

    The fix... in the web.config

    I solved it.
    In my web.config there were a couple of http modules that were causing conflicts when loaded for php pages. I had to modify the following settings:
    <modules runAllManagedModulesForAllRequests="false">
    <add name="RadCompression" type="Telerik.Web.UI.RadCompression" preCondition="managedHandler,integratedMode" />
    I added the preCondition="managedHandle to every http module although I think it was only this one that was causing the problem
    This prevents the handlers from being loaded on the php directories.
    I assume a different way would be to put a web.config in the PHP directory and unloading the modules.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services