FTP problems

Discussion in 'Virtuozzo Windows VPS Hosting' started by AndyLL, Aug 15, 2008.

  1. AndyLL

    AndyLL Perch

    I've never been able to connect to my VPS in passive mode. (even though I connect that way to the shared servers)

    Suddenly... in the last few days I can't connect with an active connection. I recieve an 500 invalid port command. I don't think anything with my router or firewall has changed. ( I did upgrade FileZilla but I also tried another FTP)

    I'd prefer to use the passive mode so I don't have to worry about it. Is there a way to setup the VPS to do this?

    Andy
  2. Stephen

    Stephen US Operations Staff Member

  3. AndyLL

    AndyLL Perch

    I ran the script and passive still doesn't work. I get:

    Status: Resolving IP-Address for DisneyMouseLinks.com
    Status: Connecting to 204.10.108.163:21...
    Status: Connection established, waiting for welcome message...
    Response: 220 Microsoft FTP Service
    Command: USER ***
    Response: 331 Password required for ***.
    Command: PASS *******
    Response: 230 User aspenlf logged in.
    Command: SYST
    Response: 215 Windows_NT
    Command: FEAT
    Response: 211-FEAT
    Response: SIZE
    Response: MDTM
    Response: 211 END
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is current directory.
    Command: TYPE I
    Response: 200 Type set to I.
    Command: PASV
    Response: 227 Entering Passive Mode (204,10,108,163,6,138).
    Command: LIST
    Response: 425 Can't open data connection.
    Error: Failed to retrieve directory listing
  4. Stephen

    Stephen US Operations Staff Member

    ok for a test, go to the network section and turn OFF the firewall for a moment to see if ti works after that(I don't recommend keeping it this way but it will isolate the issue to firewall on server side or something else)
  5. AndyLL

    AndyLL Perch

    That's the issue. Firewall off and it works.

    I then took a look at the firewall.... by default it only allows FTP ports 5500-5550

    It looks like the shared servers have a lot more ports available.

    It also looks like a pain to open ports in the firewall (it has to be done port by port)

    Is there a way to tell IIS what port range to use for passive connections?

    Andy
  6. Stephen

    Stephen US Operations Staff Member

    that passive ftp script I mentioned can be modified to use make more ports :)
  7. vita10

    vita10 Perch

    To: AndyLL
    I wonder if you did find solution for this problem?

    I tried the Solution Stephen suggested, I ran the script (successfully as much as i could see that in the metabase.xml) but unfortunately it did not work for me.
    After a half a day of trying and googeling I gave up and decided to use filezilla server which worked out great.

    Cheers
    Vita
  8. Stephen

    Stephen US Operations Staff Member

    In many ways filezilla server is great, if it is working for you go for it :)

    I wish more Control Panels officially supported it.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services