mssql connect

Discussion in 'Microsoft Development' started by fawaz, Jan 9, 2004.

  1. fawaz

    fawaz Guppy

    Hi all
    i have recently regestered at jodohost and I think this service is great. i am having a problem to connect to the sql database using sql enterprize manager. the steps i am using to connect:
    1. i am using client network utility to connect using tcp/ip to the ip address of my sql server 66.36.228.118 (mssql1.jodoshared.com) at default port number 1433

    2. i entered the enterprize manager and choose the connection done in the first step. added my username and password for sql server but i get an error (preloginhandshake)

    3. my username and password are correct because i am able to enter to the online database admin at http://sqladmin.jodohost.com

    i have even tried to connect using this site http://www.aspenterprisemanager.com they offer a demo on the right but with no luck. (note: admin give this a try)

    is anybody conneted to mssql1.jodoshared.com able to connect using the sql enterprize manager. i am convinced that remote connection other than http://sqladmin.jodohost.com is not possible.
  2. ungrounded

    ungrounded Perch

    Yep! Works great! I'm not sure what you're refering to in step 1, but in EM I have the connection set up simply with the IP Address, UserName, and Password.

    Just start the SQL Server Registration Wizard - enter the IP address for the server name, select SQL Server Authentication, enter your Login name and Password and you should be all set.

    This is all assuming that you're not stuck behind a firewall that will block such a connection (like my IT dept does at work).

    Good Luck! It works great!
  3. fawaz

    fawaz Guppy

    Hi ungrounded
    Thanks for the reply, i have tried that with no luck. if you are connected to mssql1 and it works for you then it has to be at my end, this is driving me crazy ;(
  4. hatton

    hatton Perch

    What version of Enterprise Manager are you running? (Go to Help - About SQL Enterpise Manager to find out). Jodo runs SQL 2000 so if you're running EM 7 or lower you won't be able to connect. You can download an evaluation copy of SQL 2000 and install it, the EM for the demos don't expire.
  5. fawaz

    fawaz Guppy

    i have version EM 8.0 which comes with sql 2000 server.
    in the mean time i am going to use http://sqladmin.jodohost.com to admin my db until i figure this out.
    Thanks alot for your help
  6. hatton

    hatton Perch

    Are you able to use EM to connect to any other database server?
  7. fawaz

    fawaz Guppy

    i am able to connect to my localhost through EM. i don't have any other server to connect to to test EM.
  8. hatton

    hatton Perch

    Reason I asked is to see if there might be something interfering with your outbound connection on port 1433. Perhaps you've got a firewall or strict routing going on that is causing the issue.

    Try opening up a command window and running the following command:
    telnet mssql1.jodoshared.com 1433

    If it connects correctly then your screen will go blank. Hit Ctrl-] (left brace) to pull up a menu and hit q and enter. This will close the connection.

    If it doesn't connect then there is something on your end blocking your conntection to the database server.
  9. fawaz

    fawaz Guppy

    Hi again
    well i tried that and i was able to telnet to mssql1 (i got the black screen)
    i will try to find another machine to connect from and let you knwo.
    Thanks for your help
  10. hatton

    hatton Perch

    So it's letting you get in and through, that's a good thing :)

    I'm just re-reading the thread, you initially mentioned that you entered in the direct IP address of the SQL Server here at JodoHost. For grins I tried duplicating your setup and it's working fine for me.

    The error that it's throwing (PreLoginHandshake) I could only find a handfull of references for on Google. The one that makes the most sense -

    When you add your SQL Server registration, make sure that you are selecting "SQL Server Authentication" as opposed to "Windows Authentication".

    Alternately, you may want to download and install the latest SQL Server Service Pack (3a) from http://www.microsoft.com/sql/downloads/2000/sp3.asp

    With SP3 you should get a fresh install of the MDAC which will probably cure any ails you may have ;)
  11. riggers

    riggers Guppy

    Also make sure that the SQL Server Client Network Utility is configured correctly....
  12. mikhail

    mikhail Guppy

    I am experiencing exactly the same problem. I've tried telnet and it works fine but Enterprice manager connection fails with (PreLoginHandShake()) problem.

    Did you guys figure out what to do ? I've tried connection to 6 different servers on different networks and all failed !

    8o
  13. hatton

    hatton Perch

    You've gone through the thread, did you download the SP and run it? I'm not sure if any of this solved Fawaz's problem, he never posted it here.
  14. mikhail

    mikhail Guppy

    Yes, I did... I've reinstalled SQL Server completely...installed service pack 3a and still getting the same problem.. do you think it may be related somehow that my cable connection provider had enabled some new security rules (I am using Comcast !)

    Thanks
  15. riggers

    riggers Guppy

    are you certain that you are using tcp/ip to connect and not named pipes?
  16. mikhail

    mikhail Guppy

    Yes, in fact I've created aliases for all server using Client Network Utility.

    I made progress after that changes, I can connect to servers in the Enterprise manager.

    2 things still do no work:
    1. Query Analyzer gives an error message (Connection link Failure) while connecting to the same servers
    2. SQL Server Agent gives a timeout when clicking on the Jobs to get the list of jobs...

    Why ????
  17. ungrounded

    ungrounded Perch

    1. No clue - sorry.
    2. You can't create/run jobs on JodoHost's SQL Server.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services