Mail Server Migration

Dated: Dec 29, 2004

We have decided to move the mail server off the CP server and onto a redudant new server that would exclusively dedicated to mail. This has been done so as in the recent months, with the latest version of Hsphere, we have encountered one major as well as some minor issues with qmail

The shift is scheduled to take place on Jan 6th, 2AM EST. No disruption of services will occur, the change would be 100% transparent.

The shift, along with automated fail-over for our mail servers that we’d introduce on Jan 6th will help in ensuring 100% uptime on our mail servers

We have shifted the scheduled shift one day back to Jan 5, 2AM EST

We expect NO DOWNTIME during this entire shift. The following would be performed during the shift (I have received requests to explain how it’d be carried out)

  1. New P4 2.8GHZ HT server with 200GBx2 RAID1 SATA and 2GB of RAM setup. QMAIL installed
  2. RSYNC would be setup to copy data from cp server to the new mail server.
  3. After a period of time, we’d setup QMAIL to redirect all POP3/SMTP traffic to the new mail server while we test out everything and ensure all systems are performing at 100%
  4. Once things have been verified, we will be unbinding the mail server IP from the cp server and binding it to the new mail server. Shift would be complete

Absolutely NO change in mail server IP or DNS propogation is involved

Once the shift is completed, we’d implement fail-over for our mail server to ensure that in the future if our mail server ever goes down, our backup mail server takes over

Control panel is being stopped for 1 hour, to avoid any kind of problem in mail data migration.

Control panel is up now.

We have disabled singups on the mailserver, as the new accounts may get lost in the migration process. It will be enabled in around 3 hours.

Due to this any new account signups/domain creation may see an error like this:
"
Failed to add new resource.
There is no host available for signup, group 3
"
Kindly defer this until the singups are enabled again.

Mail server signups have been reactivated

Migration was successfully completed sometime ago

We are working to fix webmail, antivirus and antispam

Webmail has been fixed

Antivirus is working. Anti-spam remains…

There is an incoming/outgoing email delay of 40 to 60 minutes…

We are working to speed that up..

The actual delay is 60 to 120 minutes.

We should have this issue fixed very soon.. Have multiple experienced admins working on it

We have stopped qmail for 5min to run a qmail queue fixer.
Standbyserver is on to take care of incoming mail in this period

The delay only affects incoming email

As an estimate, I’d say we should fix the delay issue in 120 minux max but I’m hoping much sooner

We have put up a temporary solution to the queue issue
All email is being instantly received now

There appears to be a hardware issue causing excessive CPU usage on the machine that caused the delay in incoming email being processed

About 5000 email that was in the local mail queue that had to be pushed into mail boxes has been removed and will be put back in queue in 60min

Webmail, antivirus and all services are functioning now

We are stopping qmail for 5 minutes as we reimport the 5000 emails that were to be processed

Issue Resolved

The mail server has now been switched (transparently) to a Dual XEON 2.4GHZ server with 2GB RAM and a 73GBx2 SCSI RAID1 Hot-Swap configuration

Server running excellently and migration 100% complete

Horde WebMail is having issues that may take time to fix
We request customers to use SqWebMail and SquirrelMail till then

Horde WebMail has been fixed