Can we use Management Studio to connect to db?

Discussion in 'Database Support' started by Sailor, Feb 5, 2009.

  1. Sailor

    Sailor Perch

    I installed the free SQLExpress with Management Studio. I seem to be able to connect, and see the list of databases. In connection properties i tell it to connect only to my database. However, if I try to run a query I get error "Cannot execute script - Unable to start TransactSQL debugger ....."

    If I try to look at the list of databases I get error:
    "Server user 'my_sql_admin_name' is not a valid user in database 'actinet_main'"

    I saw a previous old thread that maybe we're not allowed to connect with Management Studio. Is there some way around this, or how can we otherwise connect?

    thanks
  2. Stephen

    Stephen US Operations Staff Member

    you should not see errors about another user's db unless you clicked their DB, about TransactSQL, what kind of query are you trying to run?
  3. Sailor

    Sailor Perch

    Stephen,
    It's just a regular select query. However, I may have solved the problem. On the server connections property screen there is a button "Options >>"
    On the Connection properties tab, I selected my database from the dropdown. Then when I disconnect/reconnect, I can now run queries.
    I still get an error if I try to click the expand databases folder (in the left pane). This is how I used to find my database when I used AquaData Studio. But now I am able to run queries, so I think this is settled.
    Thanks
  4. Sailor

    Sailor Perch

    btw, the error I was getting was "Server user 'my_sql_admin_name' is not a valid user in database 'actinet_main"
    I'm not trying to connect to anyone else's server, and actinet_main isn't even alphabetically the first in the list, so not sure what's causing that error.
  5. timruns

    timruns Perch

    Weird, I have this exact problem. Trying to his MSSQL 9 with MSSQL Management Studio. I can't use the explorer at all to find (or expand) my DBs.
  6. Sailor

    Sailor Perch

    Actually, the problem was only temporarily solved. I was not connecting to the SQL Server for a couple of weeks, but when I tried yesterday I again get the error "Server user 'my_sql_admin_name' is not a valid user in database 'actinet_main'" if I try to expand the list of databases.

    I am in fact connected to the database (I have this set in connection properties). And "actinet_main" isn't even the first database on the list, so now sure why I'm getting this error when I'm not in any way trying to connect to that db.

    However, I've found a workaround:
    After I connect to the server, don't try to expand the list of databases.
    Open a new query window and type this:
    USE my_database_name
    Run that query and from that point forward I can do my normal select or update queries on my own db.

    Not ideal, but it let's me work. I'd still like to see why I can't expand the list of dbs to view my own. I occasionally need to do this if I want to see my own tables, or make a table change (I know I can do this via SQL, but I'm not that fluent yet). Having a GUI view of my tables would be nice.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services