Directory Access Denied 500 error

Discussion in 'H-Sphere Shared Hosting' started by legalg, Jul 27, 2010.

  1. legalg

    legalg Guppy

    We should be able see a dir listing when accessed externally, but I just get a 500 error. Can we set a specific htaccess file for that directory and create a username/password for it? How can I access that directory even without a username/password?

    What should our .htaccess file look like), and do we have a user/pass set up for the client? I couldn't find any helpful info in the forums on this; .htaccess questions are all Windows related it seems.
  2. Stephen

    Stephen US Operations Staff Member

    for user and pass protection you can set it via webshell (protection wizard)

    for directory listing, did you see the top portion of web options of the domain? there it will have a listing for allow directory listing or not.
  3. legalg

    legalg Guppy

    I have directory listing set to "fancy". Yet when I go to the directory I want to view I still receive the 403 error.

    I have created a .htaccess file with authentication. I enter the correct information and it still does not let me in.

    The .htaccess has:

    ### HT_PROTECT_START ###
    AuthType basic
    AuthName "Secured area"
    AuthUserFile /hsphere/local/home/username/.htmaster/.ok_user
    Require valid-user
    ### HT_PROTECT_END ###
  4. legalg

    legalg Guppy

    I have even used the "enable" option instead of "fancy" and it still does not work.
  5. Stephen

    Stephen US Operations Staff Member

    This is not my expert area :) I would recommend a ticket, it should work set to enabled in the CP. Make sure however that you click 'apply changes' (or wait 15-20 minutes)

    btw just for safety, removed your username.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services