Help with access database

Discussion in 'Database Support' started by jhoelz, Oct 16, 2003.

  1. jhoelz

    jhoelz Perch

    I need some help connecting to my Access database.
    I have had you enable Parent Paths.
    I have ftp'd a databse (mdb) file to my root directory (same level as and I have tried to connect to it using the following strings (this is for a webwiz forum)

    strCon = "DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=" & strDbPathAndName
    the path used as follows...
    strPortalDbPathAndName = Server.MapPath("../mydb.mdb")
    error message...
    Microsoft OLE DB Provider for ODBC Drivers error '80004005'

    [Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x684 Thread 0xcb4 DBC 0xa9d3024 Jet'.

    /portal/forum/admin/functions/portal_connections.asp, line 62

    The other string is...
    strCon = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" & strDbPathAndName
    the path used...
    strPortalDbPathAndName = Server.MapPath("../mydb.mdb")
    Microsoft JET Database Engine error '80004005'

    Could not find file 'D:\hshome\jhoelz\\mydb.mdb'.

    /portal/forum/admin/functions/portal_connections.asp, line 62

    What could I be doing wrong?
    I want to use a dsn less connection if possible..

    I have also installed a MsSql db and when I try to access that I get the following...

    Microsoft OLE DB Provider for SQL Server error '80040e09'

    EXECUTE permission denied on object 'wwfSpActiveUsersWhereIPis', database 'jhoelz_drport', owner 'dbo'.

    /portal/forum/includes/active_users_inc.asp, line 85

    Thanks for your help
  2. Dave

    Dave Perch

    Your SQL Server problem is that your username on SQL Server is not in the DB Owner (DBO) group. JodoHost must put your username into this group for you. I had the same problem.
  3. Dave

    Dave Perch

    I used to have the Access version of WWF running on my site, I have since changed to the SQL Server version. With Access, I used the hardcoded path in the strDbPathAndName variable. The reason I did this was it made it easier to access the database, which I put in the root directory, inside a Database directory, in a single defined connection string, instead of multiple ones for the subdirectories inside the Forum directory, like the admin directory. (If that makes any sense.) There appears to be no reason not to use hardcoded paths. (I already asked that question here.) If you change webhosts it's easy enough just to change your strDbPathAndName variable again.

    If you don't want to use a hardcoded path, if the database is OUTSIDE of your site directory, try using ../../mydb.mdb instead.

    If you get the SQL Server version going you won't have to worry about the path problem. I think I may have given the correct answer to the SQL problem you were having in my previous post.

    Good luck!
  4. jhoelz

    jhoelz Perch

    Will someone from Jodohost read this and set this up, or do I need to send them a support ticket?
  5. Hawkeye

    Hawkeye Perch

    I am using WWF just fine here with an Access database by setting up the database at the root level as Dave suggested. Just make sure your relative paths are correct.

    Root level would be "../database.mdb" for instance.

    Note that root level is NOT inside your folder - it is on the same level.
  6. Yash

    Yash Bass

    Please submit a ticket. We need to know other account details like the server you are on
  7. jhoelz

    jhoelz Perch

    Thanks all, ticket has been sent and MSSQL db is working perfect.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services