I am not happy with Jodohost's tech support.

Discussion in 'H-Sphere Shared Hosting' started by tocheer4, Aug 25, 2005.

  1. antic

    antic Perch

    I don't want to get on anyone's bad side here, but I do think support responses could have been a little more helpful in this case, instead of responding with "nothing's wrong" which, while it is probably true, can be frustrating to hear when advice and suggestions are what people need to hear sometimes, just to give them something to work with, even if they're just stabs in the dark.

    Just an innocent observation! :bsofa:
  2. Stephen

    Stephen US Operations Staff Member

    Antic, I had no clue we were even talking CF until a 1 hour long livechat transcript with one of the tech support agents, as every single link we were given was html/html, NOT CFM, so I was not even looking into any CF server issues.

    The issue is CF forces UTF-8 by default, and you must specify if it is non utf-8, the error indicates syntax error from what I saw in the error.
  3. Stephen

    Stephen US Operations Staff Member

    Antic, read it all, it is about "html/html" not working, and all the links we were given was for html files, so we were confused, and looking at IIS configs, NO CF configs. I saw some CF pages,but we were never told that is where the errors were found. :(
  4. antic

    antic Perch

    No probs, sorry if my comment was out of context. Only good intentions, no offense intended! :)
  5. tocheer4

    tocheer4 Guppy

    First I want to thank all people for helping me on this coldfusion issue. It's been more than a week now and problem stays.

    I code all pages using fusebox methodology.

    Before I transferred my files to Jodohost, I just put
    <meta http-equiv="Content-Type" content="text/html; charset=gb2312"> at the head page to force page to display Chinese in gb2312. And Everything worked fine at another hosting place.

    But after moving all files to Jodohost, nothing worked.

    Through the process, I noticed couple of things.
    1) JodoHost, actually Coldfusion, server did default all language to UTF-08
    2) JodoHost's Coldfusion server mya not up=to-date on Coldfusion server patchs.

    3) According to Coldfusion docs, user can alter teh default encoding UTF-8 to otehr encoding by using cfcontent tag.

    But this tag may not be enabled on JodoHost server.

    Now the java runtime issue is solved. Stephen, could you please check whether you guys enable cfcontent on teh coldfusion server?


    Thanks
  6. tocheer4

    tocheer4 Guppy

    First I want to thank all people for helping me on this coldfusion issue. It's been more than a week now and problem stays.

    I coded all pages using fusebox methodology. So code is trully modulated. User rarely see cfm pages except the index.cfm. That's teh reason you only saw html pages.

    Before I transferred my files to Jodohost, I just put
    <meta http-equiv="Content-Type" content="text/html; charset=gb2312"> at the head page to force page to display Chinese in gb2312. And Everything worked fine at another hosting place.

    But after moving all files to Jodohost, nothing worked.

    Through the process, I noticed couple of things.
    1) JodoHost, actually Coldfusion, server did default all language to UTF-08
    2) JodoHost's Coldfusion server mya not up-to-date on Coldfusion server patchs.

    3) According to Coldfusion docs, user can alter the default encoding UTF-8 to other encoding by using cfcontent tag.

    But this tag may not be enabled on JodoHost server.

    Now the java runtime issue is solved. Stephen, could you please check whether you guys enable cfcontent on teh coldfusion server?


    Thanks
  7. Stephen

    Stephen US Operations Staff Member

    1) JodoHost, actually Coldfusion, server did default all language to UTF-08

    That is the way the CF server ships, we can't go changing all of that now.

    2) JodoHost's Coldfusion server mya not up=to-date on Coldfusion server patchs.

    Yes, the server is up to date with CFMX 6.1 Patches, we do NOT have MX 7, and do not claim to.

    3) According to Coldfusion docs, user can alter teh default encoding UTF-8 to otehr encoding by using cfcontent tag.

    You can do this, the tag is not disabled in resource security.
  8. tocheer4

    tocheer4 Guppy

    Thanks for the reply

    Try to make things simple, I created two file under seattle-chinese.com

    seattle-chinese.com/zz1.html and seattle-chinese.com/zz1.cfm. Same file with Chinese characters in them. only zz1.cfm with extra line at the top.
    <cfcontent type="text/html; charset=gb2312">

    But zz1.html works fine and zz1.cfm does not.

    Why????





  9. Stephen

    Stephen US Operations Staff Member

    Because you need to tell CF what language it is, and it does not read the meta tags.

    It needs cf tags like this:
    <cfprocessingdirective pageencoding=" encoding ">
    Typically, you assign one of the following values to encoding :

    EUC-JP (Japanese)
    EUC-KR (Korean)
    ISO-8859-1 (Western European and English)
    SHIFT_JIS (Japanese)
    UTF-8 (All Languages)


    I sadly do not know the CF abbreviation for Chinese :(
  10. tocheer4

    tocheer4 Guppy

    I fixed the problem. Now seattle-chinese.com can display Chinese in gb2312 instead of UTF-08.

    Just want to say thank you all. At least for now. :)

    Tocheer4
  11. tocheer4

    tocheer4 Guppy

    Just saw your reply. And I found out the cfprocessingdirective too.

    Thanks Stephen for your great support.

    Tocheer4

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services