Mail won't send immediately

Discussion in 'Email Support' started by kujo2123, Oct 3, 2012.

  1. kujo2123

    kujo2123 Perch

    Have an interesting problem. Have a customer with a mix of windows live mail, outlook, and MacMail. All of them are set to send through our JH mail servers, and have the "send immediately" checked, and outgoing mail port 587. However, when they send a message, it goes to the outbox with a timeout error. They go into the outbox, hit resend, and the messages goes. This happens on simple test text only messages, and ones with attachments, and all of their workstations (PC and Mac, multiple email clients).. JH has checked the mail server and found no issues. I've narrowed it down, I believe, to something happening with their ISP, but I don't know what to tell them as they refuse to set up a simple test box for me. Our customer even had a consultant come on site with their laptop, connected to our test mail account, and it worked fine for them from their main office, but did the same pause/timeout error on initial send when at my customer's office.

    Has anyone run into this? If so, any suggestions on how I can try to get the ISP to do something to fix it?
  2. Stephen

    Stephen US Operations Staff Member

    Could it be that send immediately isn't doing an SMTP Auth, but to outbox is?
  3. kujo2123

    kujo2123 Perch

    I'm not sure what you mean. It is checked to use SMTP authentication. I did another test, I set them up with a test email account on our google mail accounts, and had them use POP3 and SMTP, and that worked immediately. Changed them back to their regular server on JH mail servers, and same delay.
  4. Stephen

    Stephen US Operations Staff Member

    What I meant was maybe it is not authorizing the send for some reason on the send immediate, but is when it does the full check and send. We don't have any built in delay on the email such as this, which obviously you know since not seeing it yourself. I can't say I know of any ISP side issue that would make this either.
  5. kujo2123

    kujo2123 Perch

    I have never heard about a setting, on 3 different clients, that would have it not authorize and then authorize.

    I'm truly at a loss as to what to do. I set up another test account on a different JH mail server on one of our other client's domains, and same issue. Even had them switch to SSL port 465, and nothing. It's something between their ISP and JH mail servers.. Just don't know what else to look at.
  6. SachinK

    SachinK Perch

    As such, this case is only with the client's end ISP not with any other, but if you think we had some kind of issues with ISP like a block at our end, then it didn't able to send the mail even at second attempt.

    You may try to temporarily turn off firewall/AV, especially mail scanner module and then try to send email.
    If the problem persist then, you can update us about the mail server and test email id credentials on a support ticket, we'll try to check it by set up at our end as well and will let you know result.
  7. kujo2123

    kujo2123 Perch

    We already did a test with JH support and a test email account. I also set up the same test account from my home computer which goes through a different ISP, and they had a consultant do the same. Only when they are at the customer's office connecting to JH mail servers is there a problem.
  8. Stephen

    Stephen US Operations Staff Member

    It must be ISP, really wish I had an answer as to what it could be, I've got a little experience on that side of operations and never had anything like this (prior to hosting, not so much cable/dsl days)

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services