uploading files during trial account

Discussion in 'H-Sphere Shared Hosting' started by yorri, Jun 25, 2003.

  1. yorri

    yorri Perch

    I signed up for a trial account and logged into my ftp but there are no directories or files and I cannot upload files.

    Is this normal? I was able to log in but looks like I can't do anything beyond this.
  2. StPatrick

    StPatrick Perch

    Sometimes it depends on FTP client. If you got into such situation, here is a tip:

    If you can run FTP commands (e.g. have a command line), then type: "cd your_user_name "

    Else, just setup your ftp client to go directly to the dirictory names as your username. How - it really depends on FTP client :)
  3. yorri

    yorri Perch

    well I am using Dreamweaver which shows the directory structure and there is nothing showing at all.

    I then tried to upload a basic htm file and it wouldn't allow me.

    I shouldn't have to do more than this. The login works but there are no directories or files.
  4. Yash

    Yash Bass

    Sorry, i missed this. make sure you are using port/active mode for transferring your files
  5. yorri

    yorri Perch

    I don't have passive mode checked and there is no active mode to check. I think this is dreamweaver default. I will try a standalone ftp client now and see if there is any difference.
  6. Yash

    Yash Bass

    Surely dreamweaver must have some option. If not, a standard FTP client would do the trick
  7. yorri

    yorri Perch

    Well I just tried WS-FTP and it logs in fine just like Dreamweaver but then it kinda hangs like it is waiting for something to happen.

    I then tried the same using the Win XP ftp dos prompt ftp and it logged in fine as well but when I type dir..it hangs.
  8. Yash

    Yash Bass

    Could you paste the log file here. Are you sure its not issuing a PASV command?

    make sure it is using port/active mode. Go to WS-FTP's settings. There would definately be an option somewhere there to either disable PASV mode or turn on Active/PORT mode. Read its documentation. I use FlashFXP and it has an option for active mode which I have checked and I am able to connect without a problem
  9. yorri

    yorri Perch

    I have disabled passive mode, I told you that above.

    It hangs when it gives the port command.

    This is the log

    connecting to 139.81.148.24:21
    Connected to 139.81.148.24 port 21
    220 WIN4 Microsoft FTP Service (Version 5.0).
    USER Yendel
    331 Password required for Yendel.
    PASS (hidden)
    230 User Yendel logged in.
    PWD
    257 "/Yendel" is current directory.
    SYST
    215 Windows_NT version 5.0
    Host type (S): Microsoft NT
    PORT 192,168,2,102,9,83

    This is where it stops working.
  10. Yash

    Yash Bass

    We're looking into this
  11. Yash

    Yash Bass

    I tried connecting using CuteFTP Pro. Had no problem

    STATUS:> Getting listing ""...
    STATUS:> Resolving host name win4.jodohost.com...
    STATUS:> Host name win4.jodohost.com resolved: ip = 139.81.148.24.
    STATUS:> Connecting to ftp server win4.jodohost.com:21 (ip = 139.81.148.24)...
    STATUS:> Socket connected. Waiting for welcome message...
    220 WIN4 Microsoft FTP Service (Version 5.0).
    STATUS:> Connected. Authenticating...
    COMMAND:> USER yendel
    331 Password required for yendel.
    COMMAND:> PASS *****
    230 User yendel logged in.
    STATUS:> Login successful.
    COMMAND:> PWD
    257 "/yendel" is current directory.
    STATUS:> Home directory: /yendel
    COMMAND:> FEAT
    500 'FEAT': command not understood
    STATUS:> This site doesn't support the 'features' command.
    COMMAND:> REST 100
    350 Restarting at 100.
    STATUS:> This site can resume broken downloads.
    COMMAND:> TYPE A
    200 Type set to A.
    COMMAND:> REST 0
    350 Restarting at 0.
    COMMAND:> PORT 192,168,1,100,14,178
    200 PORT command successful.
    COMMAND:> LIST
    150 Opening ASCII mode data connection for /bin/ls.
    STATUS:> Accepting connection: 139.81.148.24:20.
    226 Transfer complete.
    STATUS:> Transfer complete.

    How about trying CuteFTP instead. There may be some problem with WS-FTP when it connects using PORT mode
  12. yorri

    yorri Perch

    Well I just tried Cuteftp and the same thing happens.

    I also tried flashfxp with same results.

    I can connect no problem but when it issues the port command, that is when it hangs

    I am using a hardware router..wonder if that is the problem...however is it UPNP which means it should automatically open and close ports as needed. I haven't had a problem with any other service but I have never issues the port command. Maybe there is something special about it.

    I tried putting myself outside the DMZ zone but that didn't work but I'm not confident that setting works as it should so I will bypass my router for this once just to see if it is that.

    Thank you for your patience Yash.
  13. yorri

    yorri Perch

    OK that worked. I connected directly without the use of a router and it worked fine. This is the first thing in 2 years that hasn't worked (honestly) so that is why I didn't even think of it.

    But I need the internet sharing device so I need to find out how to configure it to work with your services.

    If you know what to do that would be great because otherwise I will be unable to use your services.

    Sorry for all the troubles.
  14. yorri

    yorri Perch

    OK I did some research...

    When people are behind a Nat router, ftp clients use the DHCP assigned ip address of the local machine but it needs to use the ip address of the internet connection.

    Bulletproof FTP allows a user to enter in the ip address of the external ip(the ip of the nat router) and this will work.

    This is a HUGE pain in the A**

    so this means I cannot use Dreamweaver because of the active connection and would have to purchase (if I cannot find a ftp program that is free) bulletproof jsut to do business with you.

    This is starting to become way too complicated.

    Why don't you allow passive connections like every other host GRRRR....sorry ignore my frustration :)
  15. Yash

    Yash Bass

    Our security policy was developed by our system administrators. I'm going to be discussing this with them.
  16. yorri

    yorri Perch

    Well after a few more hours of research and learning.

    The only way this is going to work for me is to use a Upnp enable ftp client (of which there are none yet) or to pay $30US for bulletproof and manually configure the ip so that I can communicate with your server.

    Because I do not have a static ip, I would have to keep changing the ip in Bftp. and as I said, I use dreamweaver so this would add an extra step...which on top of the changing ip makes 2 extra steps just to publish, and I lose some of the built in site management features of dreamweaver.

    I realize that not everyone has a router but they not uncommon. I am sure this will come up again for you.

    Unless something can be done I guess will move on and look for another host and let you focus on your existing customers.

    The good thing is that we have learned a few things which is never a bad thing and if it comes up in the future for you...you will know what the problem is.

    I will wait for your response before making a decision.
  17. Yash

    Yash Bass

    We brought in an outside security firm to increase the security on our systems at a very significant cost. This was done because 2 of our boxes were hacked within the last 60 days prior to the change.
    They determined that all intrusions occurred on the higher Ports 1000 - 5000 those are the ones that passive mode creates a connection to.
    I am truly sorry that this has posed a problem for you but we will have to stick to this policy in order to ensure security for all our customers. If you need any assitance in finding another good host that meets your requirements, I could definately help.
  18. WineIsGood

    WineIsGood Perch

    Have you tried FTP Explorer? I use it from behind our firewall and it works fine. It's free too.
    -Dave
  19. Yash

    Yash Bass

    No, we are able to connect from our office to the servers in Atlanta through routers just fine. This issue is only a problem with NAT. And by the way, there are some FTP programs that work with NAT. Maybe a little more research could yield some results
  20. yorri

    yorri Perch

    I should have been more specific and saying Nat..yes. but that is what most people at home using your service would be using.

    wineisgood...a firewall is not the problem.

    Well after 2 hours of searching I found none that specifically work with nat, however as I said, bftp will allow me to manually enter my isp's ip which solves the problem but as I mentioned..it's dynamic and I lose some site management benefits of dreamweaver.

    It would be great if there was a program that could work as a layer in between the ftp and the nat router.

    Oh well...

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services