Wordpress not sending mail

Discussion in 'Email Support' started by jph, Dec 19, 2008.

  1. jph

    jph Perch

    Hey all,
    I am a noob with Wordpress blogs, but have installed it for a couple clients here on their Windows accounts.

    Everything works great, except when a user visits the blog and tries to Register himself, Wordpress says it is sending an email with his new password. That never happens. There may be other times Wordpress is also failing to send mail (like admin notifications) But I am trying to keep the issue simple. Just know that I do not think I have seen Wordpress successfully send any email.

    The Wordpress FAQ says: "Wordpress uses the standard php mail function, which uses sendmail. No account information is needed. This is not generally a problem if you're using a hosting service, but if you're using your own box and don't have an SMTP server, the mail won't ever send. If you're using a *NIX box, you should have either postfix or sendmail on your machine; you'll just need to set them up (google for how-to's). If you don't want to go through setting up a complete mail server on you *NIX box you may find ssmtp useful - it provides "A secure, effective and simple way of getting mail off a system to your mail hub". On a Windows machine, try a sendmail emulator like Glob SendMail."

    And then their forum is full of people who have tried and failed using lots of different suggestions, different answers seem to work but only sometimes... nobody seems to have a magic bullet....

    SO... Has anyone here installed Wordpress on a Windows account and fixed this sendmail issue? Or have a suggestion that should work specifically on jodo?

  2. bro

    bro Perch

    I've a similar problem with Movable Type on Windows.

    phpinfo says "Internal Sendmail Support for Windows" is enabled, but there's no sendmail_path (and Movable Type says the sendmail path is invalid).

    What is it?

    Failing that, has anyone had success using Windows smtp with Movable type. I've tried a bunch of settings but nothing works.
  3. Stephen

    Stephen US Operations Staff Member

    windows doesn't have sendmail it will just be mail()
  4. Manish

    Manish Bass

    Have you tried to set correct SMTP settings in PHP.ini file ? If not, you have to do. You can send us domain name in ticket. We will upload php.ini in your domain according to PHP version.

    I never installed wordpress on windows but once i fixed it for one customer. If you send us ticket, we will gladly check it.
  5. bro

    bro Perch

    Sorry to stomp all over the Wordpress thread, but I did get Sendmail working in Movable Type 3.35 on Windows (which may help the Wordpress setup).

    Here's how....

    1. Get MT to the point where it all works except that when you try to send a notification mail it tells you the sendmail path is invalid. If you don't get that far, you're wasting your time with the rest of this.

    2. Get the latest sendmail.pm file from the net.

    3. In a simple text editor (I used Notepad), edit the smtp example line to

    'smtp' => [ qw( mail.yourdomain.com ) ],

    or whatever your mail server is.

    4. Create a folder at /cgi-bin/MT/extlib/Mail and upload the sendmail.pm file to it in ascii mode. (Your MT folder may not be at cgi-bin/MT.)

    5. In php.ini in your root folder (you may have to make one), add or edit the lines:

    [mail function]
    SMTP = mail.yourdomain.com
    smtp_port = 25
    sendmail_path = http://www.yourdomain.com/cgi-bin/MT/extlib/Mail/

    (Ignore the 'for linux only' warning if it's there)

    That worked for me. Pity I had to spend hours figuring it out myself, and that no-one associated with MT or the so-called 'open source' community could find the time to explain it.
  6. Stephen

    Stephen US Operations Staff Member

    interesting fix!
  7. bro

    bro Perch

    oops, one more thing

    Under your database settings in mt-config.cgi add or edit the lines

    MailTransfer smtp
    SMTPServer mail.yourdomain.com
  8. bro

    bro Perch

    Welll, it's a Perl module, not a specific Linux format, so ActivePerl on Windows should be able to run it just fine (as long as it knows where it is). I think the problem often comes with trying to use localhost rather than smtp on Windows. This doesn't seem to work at all.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services