How to setup DotNetNuke with SQL Server


I'm having a nightmarish time trying to setup DotNetNuke with SQL Server. I keep getting insufficient permissions errors and application errors.

How can I SSH or telnet to my account and then run my domain as 'localhost' to setup DNN? Or what do I need to do for it? ?(

I'm used to dedicated servers with root access, and this hosting thing is throwing me for a bit of a loop. ?(

Any help is appreciated.

This is a linux account?

Just open a ticket with instructions on how to install and one of our administrators would do it for you
If you take a VPS account, you will get root access. ON a shared Linux environment, we consider it a security risk
It's a Windows account - Silver Plan.

I've set up all the files properly, but to install DNN, it needs to run as localhost first.

I'll open a ticket again. I just hate to bother you guys when this is stuff that I usually do myself...
Yash said:
You are not bothering us, that's our job :)

Yeah, but customer support is always expensive in terms of man-hours it takes. I spent an entire man-week trying to help a customer on a problem. It ended up as user error... :evil: That kind of stuff can really put you behind the eight-ball. I don't want to be that kind of customer, especially for easy stuff like this that I usually do myself in 5 minutes.

Anyways, cheers and thanks for the help - I put in a ticket with how to get DNN up and running.

Followup: How to setup DotNetNuke with SQL Server

Ok, so if anyone else has the same problem, here's the down & dirty on it:

1) Create the DB & upload the files as normal for DNN.
2) Make sure your connection strings are all correct.
3) Issue a Jodohost support ticket asking for full ASP.NET permissions, correct ASP.NET permissions for your DNN folder/site (write, modify, etc.), and that they run the application as localhost.


Thanks again guys - it's up and running fine now :)
Re: Followup: How to setup DotNetNuke with SQL Server

You have to change the owner of the stored procedures from your database user to dbo...or vice versa. I had a hell of a time getting it to work but it all had to do with ownership of the stored procedures and/or tables...can't remember precisely. I found some scripts that I ran to change the permissions through sql enterprise manager and it worked from then on.

Also, if you are on the windows 2003 server, I was never able to get it working like I did on the windows 2000 server because of permission errors. I requested full access to the .net account but I don't think it was configured in the necessary way because it never worked but I was able to get it working without a fuss on my home server.
I saw the same problem at first too, but to populate the database what I did was to export my database from my home system into the one on Jodohost using Enterprise Manager.
I'm having an issue setting up DNN. I opened a taking to give full permission to the DNN folder. But each time I launch the page I receive:

Server Error in '/' Application.

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<customErrors mode="Off"/>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

Is the error message have to do something with premissions?
Legends92: If you change the web.config to
<customErrors mode="Off"/>
It will show you more detailed error message.

I've finnaly just got it running on my site, if it helps i think the way to go is create the db on your local machine (in msde or sql server) then upload from that using enterprise manager. I did an export of all database objects. (You need to select options and make sure roles/security dont get uploaded or it fails) when it gets uploaded all the tables/procs will have 'dbo' as the owner, not your admin user.

Did everything that this thread has asked for and my site(s) have been down now for over 5 hours... Bah... Shoulda done it myself...

Besides the ticket to get the user full permissions i got it running no problem. For the dbo issue edit the web.config near the connection string settings, set the dbo = to whatever user you created for the database. ex
<add name = "SqlDataProvider"
type = "DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider"
connectionString = "Server=localhost;Database=DotNetNuke;uid=;pwd=;"
providerPath = "~\Providers\DataProviders\SqlDataProvider\"
objectQualifier = ""
databaseOwner = "dbo"

Change dbo to whatever login you created for the database. As for the other error I found that was from trying to use the dns to the sql server instead of the ip. As soon as i switched the IP it worked fine.
Hmmm I thought I had it working but I apparently wasn't running off of sql server. Has anyone else got the install scripts to work? Or should i just resort to upload in a local copy?
Re: Followup: How to setup DotNetNuke with SQL Server

Renegade said:
and that they run the application as localhost.

The other instructions make perfect sense but what does this part mean?

Thanks a lot,

Mark :)
DNN install: What worked for me...

Pretty much in this order...

1) Ask Jodo support to give ASPNET (and NetworkService if 2003 Server) account full read and write permission in your root web.

2) Ask Jodo support to set your MS SQL Server login as DBO in your database.

3) Make sure your DNN web.config has correct connection settings.

4) Must copy DNN files to your root web, not in a subfolder.

All DNN tables and stored procs -must- be owned by DBO. If your login is DBO, then this should happen when DNN does it's setup thing.

If you want a "child" portal running in a subfolder, you can set that up from the "Host" controls in DNN.
DNN: How to overcome the WWW error?

When you first run DNN and it installs itself, your portal is keyed to the URL. Which (for me anyway) causes an error if I try to use "www" when running my site.

For example:

I used this Url during DNN setup:

Get error now if I try:

Do you guys get this too? Is there a fix?

Thanks for replies,

Mark :)