Unable to see db on MSSQL11

Discussion in 'Database Support' started by Sailor, Mar 23, 2009.

  1. Sailor

    Sailor Perch

    In client CP I created a MSSQL user and two databases on MSSQL11.
    However when I connect to it with MS Management Studio I can not see the databases I created. I get an error message if I try to issue command "USE [database name]

    On suggestion of support I also installed SQL Manager Lite. I get the same issue. I can see the user I created, but not the databases.

    I know I am connecting, because my user logs in and I can see system databases, but no way to see my own dbs. Yet I go back to user CP and both databases are definitely there.

    Has anyone connected to MSSQL11, or any idea what could be the problem?

    thanks
  2. Stephen

    Stephen US Operations Staff Member

    On SQL manager you need to put in the DB name during the wizrd.

    Attached Files:

  3. Sailor

    Sailor Perch

    Stephen,
    I just spent the last few weeks learning MS SQL Server Management Studio, accessing my database on mssql9, so it would be nice not to have to learn yet another interface. Management Studio seems to be able to get to mssql9 without problem, so why would it not work on mssql11?

    In connection properties for Management Studio I am entering the db name. I also tried doing "USE [db-name]", which works on mssql9, but I get this error:
    Could not locate entry in sysdatabases for database 'bss'.

    Note above the name of the database is truncated. Since the client username is bss-photog, could there be a problem with hyphenated names? HSphere insists on appending the first 7 characters when creating database names.
  4. Stephen

    Stephen US Operations Staff Member

    yes hyphenated names cause some problems at times. however SQL 2005 is different than SQL 2000 and the way hpshere works we have view access disabled on users for security, this is quite a long running thing, since we started offering sql 2005.
  5. Sailor

    Sailor Perch

    Ok, well that solved one problem: Apparently the hyphenated user login name was an issue, since that was also being used to name databases and users. I created a new user without the hyphen, and now I am able to connect with SQL Server Management Studio. I still need to put the database name in Server Properties.

    I still can't see my new database or any tables. However if I run the command "USE [dbname]" in a query window it now runs successfully.

    I can understand why you would turn off view access for other people's databases (I remember being surprised to see all those databases on an earlier server). But surely we should be able to view our own databases? So many operations, esp to alter tables, requires right-clicking the table name in the Object Explorer window.
  6. antic

    antic Perch

    It is a manual task (I assume) to show just one database for each user. However, I'm also peeved by this decision. What's the harm in seeing merely the names of other people's databases? Sure it *looks* strange, but show me another host where that *isn't* the case anyway? It's like that everywhere.

    Show me one other host, however, who has turned off the database view completely! I haven't come across one yet. It's a great inconvenience. :(
  7. antic

    antic Perch

    Let me correct my last post - it's not a great inconvenience, it's a major pain in the a$$. Seriously.

    I just tried using TOAD for SQL. It's a fantastic db manager, kicks EM out of the water, which really isn't a big feat anyway. But it won't work on Jodo's SQL servers, because of this insane rule of not listing database objects. Sorry, but this is not a good situation at all.

    In the first attachment below, you an see me setting up a new connection in TOAD. It seems to recognise the db object there and allow me to create the entry.

    But then when I actually connect and want to see a list of tables, it comes up with that error in attachment 2 below. "The name 'xxx' was not found in the Databases collection."

    Come on Jodo, you're supposed to be HELPING us, not putting hurdles in the way!

    Attached Files:

  8. Stephen

    Stephen US Operations Staff Member

    submit a ticket and we have a workaround for it, but it is manual for every request.
  9. antic

    antic Perch

    Thank you Stephen, that's a relief at least. Though I gather from your "tone" that you're not planning to change your policy. :p

  10. Stephen

    Stephen US Operations Staff Member

    nope, not changing it, if anything it will get more strict the amount of brute force we have to block each day is increasing, on each one I now have 1000's of /24 subnets blocked.
  11. antic

    antic Perch

    Is it possible perhaps to implement VPN for all outside connections to your SQL servers?

    There's a local company here in Perth which does that, it's very effective.

    [ed] At least then the attacks will hit your VPN server, while the SQL servers can safely disappear behind your DMZ. At least that's how I understand it.
  12. Stephen

    Stephen US Operations Staff Member

    more than possible, but then everyone gets blocked out. And we can't let people(clients) connect to an actual VPN as then it is in network for out other systems too :(

    Some ideas on it in the future, but it is going to have to be a phased change if it happens.
  13. antic

    antic Perch

    Fair enough. Your speedy support guys have just given me a new login for the db so I can see it in Mgmt Studio.
    Yay! I'm happy now and can work with that, thanks. :hail: :dance:

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services