EMail PROBLEMS

Discussion in 'H-Sphere Reseller Hosting' started by zardiw, Jul 13, 2011.

  1. zardiw

    zardiw Perch

    Ok.....I give up.......Been having EMail issues for close to a week now.....trouble tickets not being addressed in a timely manner.........but the Bottom Line is.......Why can't I EMAIL........NOTHING has changed...........
  2. zardiw

    zardiw Perch

    This is what I'm getting:

    [​IMG]


    z
  3. zardiw

    zardiw Perch

    What the HELL is spamhaus????????????????????????????/
  4. Stephen

    Stephen US Operations Staff Member

    Zardiw,

    that is saying your ISP IP is blocked, not ours. Spamhaus is a realtime blocklist.

    Try using port 587 for SMTP :) with authentication selected in your mail client.

    BTW you may want to remove the image if you don't want to give out your location in the world :)
  5. zardiw

    zardiw Perch

    I already AM using port 587. The PROBLEM is JodoHost EMail Server is FUBAR.......


    YOU guys are the ones using spamhaus......but something is WRONG with the settings.

    NOW I can't even EMAIl anymore.......

    We're coming up on 2 WEEKS for this problem.......TROUBLE Tickets are USELESS on this, because you are NOT addressing the PROBLEM.........z
  6. zardiw

    zardiw Perch

    Tell me WHY all of a sudden EMail has these problems......when there have been no changes for YEARS........on my end.......but now you're in a new data center and the problem has raised it's UGLY head..........
  7. zardiw

    zardiw Perch

    And the thing that REALLY pisses me off is the ping pong answer from you all.

    1. You say it's my ISP causing this.

    2. My ISP says it's YOUR problem.

    And it seems to me that my ISP has NOTHING to do with logging into MY mail server........now does it?


    z
  8. zardiw

    zardiw Perch

    For your edification. THIS is the ROOT of the problem........and YES, I AM using port 587, and I AM authenticating:

    Outbound Email Policy of Verizon Online for this IP range:

    It is the policy of Verizon Online that unauthenticated email sent from this IP address should be sent out only via the designated outbound mail server allocated to Verizon Online customers. To find the hostname of the correct mail server to use, customers should consult the original signup documentation or contact Verizon Online Technical Support.


    Removal Procedure

    Removal of IP addresses within this range from the PBL is not allowed by the netblock owner's policy.


    About The PBL

    The Spamhaus Policy Block List ("PBL") is an international anti-spam system maintained by The Spamhaus Project in conjunction with Internet Service Providers and is used by Internet networks to enforce inbound email policies. The PBL database lists end-user IP address ranges which should not be delivering unauthenticated email to any mail server except those provided for specifically for that customer's use. The PBL lists only IP addresses (not domains or email addresses).


    z
  9. zardiw

    zardiw Perch

    MORE:

    I have 'SMTP Authentication' switched ON but I'm still blocked!
    If you are absolutely sure that you have SMTP Authentication turned on properly in your email program, then contact the administrator of the mail server you are trying to send your email out through. It will usually be your ISP's mail server or your company's mail server. Ask them to check your "SMTP Authentication" settings.

    Things to check:

    * Are your outgoing mail server account, username and password correct? (check them, and remember that passwords are case-sensitive)

    * Is the SMTP authentication working correctly at your mail server? (ask your ISP to check)

    * Make sure you are connecting to your mail server's 'authenticated mail' port 587 and not the ordinary 'unauthenticated' port 25. (ask your ISP to check for you)

    * Mail servers only run spam filters such as Spamhaus PBL on port 25, so if you find you are being blocked by the PBL when you try to send mail to your mail server that means you are not communicating with the mail server on the 'authenticated' port 587 but you're still on port 25. This means your 'SMTP Authentication' is not working correctly. (ask your ISP to check for you)

    In summary, if you are being blocked by the PBL when you try to send mail from your PC or Mac to your mail server that means you are sending on port 25, which means that even though you think you have SMTP Authentication switched on, your SMTP Authentication is not working correctly. This can often be something as simple as a bad password, see "Things to check" above.
  10. Stephen

    Stephen US Operations Staff Member

    Look, you don't have to believe me, but the fact is it is your IP blocked, nothing to do with ours.

    You posted it. In your own screenshot, go to www.whatismyip.com and it would match the listed Spamhaus entry ip that you get when trying to mail at the same time(over time you may have different IP addresses so compare today's error to today's IP for example)

    The IP you have listed is not our IP, we have NO IP starting with 71.121, nor have we ever.
  11. Penhall

    Penhall Perch

    I'm surprised Verizon is disallowing your connection to an external SMTP server even when using alternate port 587. Perhaps the easiest fix is to use Verizon's SMTP servers for outgoing mail...

    Looks like a Verizon policy on SMTP use, that's what the issue looks like to me but I could be wrong.
  12. Stephen

    Stephen US Operations Staff Member

    I ran into a case in the last 2 weeks where sbcglobal (AT&T) in at least one region was blocking SMTP to anything but their smtp server, and oddly putting their smtp server in worked with no auth of any kind at all, not even an email address setup on it.
  13. Penhall

    Penhall Perch

    Yup, similar here *within the ISP's network* - if you're already on/internal to the network, no authentication required at all; some clients actually prefer to use the local ISP's SMTP because it is faster with larger emails w/attachments (given my large distance from either JH data centres)
  14. zardiw

    zardiw Perch

    You are WRONG.............Read up on PBL blocks.

    HERE's what's happening.

    The mail server is NOT supposed to check with spamhaus when stuff comes in on port 587 because that's for
    AUTHORIZED Email.......

    BUT....the mail server doesn't give a flying rat's ass where the EMail is coming from.........It checks with spamhaus ANYWAY........and guess what.....spamhaus has a list of ISP IP's.........and will BLOCK EMail coming directly from ISP IP's .........

    It's only supposed to block it if it's coming in on port 25...........NOT 587.......because guess what......when you use port 587, you have to supply a userid and password........


    SO THERE is your PROBLEM...........CHeck your SERVER.............z


    Now. When I log in to GET my EMail FIRST.............well then the server FINALLY figures out that I'm legitimate...........and THEN it lets EMails through

    If I just come in cold to send an EMail.......the SERVER says F. OFF...........I have to LOG In to GET Emails..........THEN I can send from my local IP.......
  15. zardiw

    zardiw Perch


    Verizon is NOT Blocking access to a mail server.......that's ludicrous.....Verizon sends crap whereever it's going to.

    JodoHost server USES spamhaus.......that's why this problem exists.....it's on the JODOHOST server side.......has ZERO to do with my ISP......z
  16. Stephen

    Stephen US Operations Staff Member

    Zardiw,

    It is your server that is blocked, port 587 bypasses that check.

    I use sprint for my phones, and they are on the spamhaus listing, I have to set my phone mail apps to use port 587 (not always easy!) in order to use mail, and i send dozens daily.

    This matter IS caused by your ISP IP blocked, I am glad you can finally see that, it is NOT caused by our server blocked anywhere.
  17. bro

    bro Perch

    Stephen, I'm on a different IP, but I'm also having this problem now on mail9. I'm using port 465 and authenticating using the same settings I've used for years, but it doesn't work on 587 either. I can send mail using the same settings using mail3 m****here.biz servers, through my ISP, through godaddy SMTP, and through Gmail SMTP without problems.

    Sorry to repeat what's already been said, but Spamhaus say the problem will not occur if you're using authenticated mail, so this problem should not be happening if the authentication is set up correctly. This is what Spamhaus say about this error:

    "This IP range has been identified by Spamhaus as not meeting our policy for IPs permitted to deliver unauthenticated 'direct-to-mx' email to PBL users."

    It is not a 'blocked' IP, it is simply one that is (rightly) not recognised as a mail server IP.

    "Important: If you are using any normal email software (such as Outlook, Entourage, Thunderbird, Apple Mail, etc.) and you are being blocked by this Spamhaus PBL listing when you try to send email, the reason is simply that you need to turn on "SMTP Authentication" in your email program settings."

    and "Mail servers only run spam filters such as Spamhaus PBL on port 25" (ONLY)

    and "If you are absolutely sure that you have SMTP Authentication turned on properly in your email program, then contact the administrator of the mail server you are trying to send your email out through. "

    So, just to double check what settings are supposed to work on this server, here are mine:
    Server name mail.mydomain.com or mail9.m****here.biz
    Port: 465 (also tried 587)
    username: testmail@mydomain.com
    Authentication: Normal password (also tried encrypted)
    Connection: SSL/TLS (also tried everything else)

    There is no combination of settings that seem to work on this mail server, but all other servers I've tried, including mail3, work fine.
  18. Penhall

    Penhall Perch


    Sorry, didn't mean to be ludicrous, of course ISP's would never block traffic... it all flow freely, if they started blocking traffic we might have to do something strange like setting up alternate ports or something.

    Good luck with your problem(s)
  19. LeandroJF

    LeandroJF Guppy

    Two of my clients are also having the spamhaus problems when sending mail and both are on mail9 too.

    I created an test email address in one of my clients domain and tried to send a test email, and I also receive the spamhaus message. When sending the same email through my real email adress that is located on mail5 server, i don't have any problem.
  20. Stephen

    Stephen US Operations Staff Member

    SMTP on 587 should not RBL check by the configs, but I am having techs to double check it.

    you may want to make sure that if you have an anti virus like AVAST (and I think Norton also) that does SMTP proxies, are not capturing the port and sending it via port 25 anyway.

    I am not saying that is the cause, I am having it checked, but I am saying it may be worth checking out as well.
    I know that when mail5 initially moved I had an issue from my phone as I didn't have a mail client with the ability to modify the port, and putting in the mail.domain.com:587 did not work (it works for some), so i got a new mail client with advanced options and it worked, since then the base software allows mail port settings as well.

    now I believe TLS/SSL will NOT work over port 587, only 465.

Share This Page

JodoHost - 26,000 hosting end-users in 100 countries
Plesk Web Hosting
VPS Hosting
H-Sphere Web Hosting
Other Services